use strict;
my $str = '{
"response": {
"first_name": "Степан",
"last_name": "Воробьёв",
"screen_name": "sparrowwwwww",
"sex": 2,
"relation": 7,
"bdate": "14.2.1995",
"bdate_visibility": 2,
"home_town": "Санкт-Петербург",
"country": {
"id": 1,
"title": "Россия"
},
"city": {
"id": 2,
"title": "Санкт-Петербург"
},
"status": "",
"phone": "+7 7** *** ** 92"
}
}';
my $regex = qr/"first_name":\s+"([^"]+)"[^"]+"last_name":\s+"([^"]+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}