$re = '/"first_name":\s+"([^"]+)"[^"]+"last_name":\s+"([^"]+)"/m';
$str = '{
"response": {
"first_name": "Степан",
"last_name": "Воробьёв",
"screen_name": "sparrowwwwww",
"sex": 2,
"relation": 7,
"bdate": "14.2.1995",
"bdate_visibility": 2,
"home_town": "Санкт-Петербург",
"country": {
"id": 1,
"title": "Россия"
},
"city": {
"id": 2,
"title": "Санкт-Петербург"
},
"status": "",
"phone": "+7 7** *** ** 92"
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);