import re
regex = re.compile(r"\"first_name\":\s+\"([^\"]+)\"[^\"]+\"last_name\":\s+\"([^\"]+)\"", flags=re.MULTILINE)
test_str = ("{\n"
" \"response\": {\n"
" \"first_name\": \"Степан\",\n"
" \"last_name\": \"Воробьёв\",\n"
" \"screen_name\": \"sparrowwwwww\",\n"
" \"sex\": 2,\n"
" \"relation\": 7,\n"
" \"bdate\": \"14.2.1995\",\n"
" \"bdate_visibility\": 2,\n"
" \"home_town\": \"Санкт-Петербург\",\n"
" \"country\": {\n"
" \"id\": 1,\n"
" \"title\": \"Россия\"\n"
" },\n"
" \"city\": {\n"
" \"id\": 2,\n"
" \"title\": \"Санкт-Петербург\"\n"
" },\n"
" \"status\": \"\",\n"
" \"phone\": \"+7 7** *** ** 92\"\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")