package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/localhost:\d+)$|^(https?:\/\/.+\.yourdomain\.com)$`)
var str = `http://localhost:3000
https://subdomain.yourdomain.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}