$re = '/^(https?:\/\/localhost:\d+)$|^(https?:\/\/.+\.yourdomain\.com)$/m';
$str = 'http://localhost:3000
https://subdomain.yourdomain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);