re = /^(https?:\/\/localhost:\d+)$|^(https?:\/\/.+\.yourdomain\.com)$/m
str = 'http://localhost:3000
https://subdomain.yourdomain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end