using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9\-]+)(\s+|-)";
string input = @"251-dash webm audio only | 3.18MiB 145k dash | audio only opus 145k 48k DASH audio, webm_dash
140 m4a audio only 2 | 3.07MiB 129k https | audio only mp4a.40.2 129k 44k medium, m4a_dash
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}