use strict;
my $str = '251-dash webm audio only | 3.18MiB 145k dash | audio only opus 145k 48k DASH audio, webm_dash
140 m4a audio only 2 | 3.07MiB 129k https | audio only mp4a.40.2 129k 44k medium, m4a_dash
';
my $regex = qr/^([a-zA-Z0-9\-]+)(\s+|-)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}