const regex = /^([a-zA-Z0-9\-]+)(\s+|-)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9\\-]+)(\\s+|-)', 'gm')
const str = `251-dash webm audio only | 3.18MiB 145k dash | audio only opus 145k 48k DASH audio, webm_dash
140 m4a audio only 2 | 3.07MiB 129k https | audio only mp4a.40.2 129k 44k medium, m4a_dash
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}