using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\W_](?!.*?[._]{2})[\w.]{6,18}[^\W_]$";
string input = @"foo.1bar
foo._bar
_foo.1bar
foo.1bar.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}