$re = '/^[^\W_](?!.*?[._]{2})[\w.]{6,18}[^\W_]$/m';
$str = 'foo.1bar
foo._bar
_foo.1bar
foo.1bar.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);