re = /^[^\W_](?!.*?[._]{2})[\w.]{6,18}[^\W_]$/m
str = 'foo.1bar
foo._bar
_foo.1bar
foo.1bar.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end