import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "IF\\[([^][]*(?:(?<!\\bIF)\\[[^][]*][^][]*)*)]";
final String string = "1. IF[A != B; C[0]; D]\n"
+ "2. IF[A != B; IF[E < F; ...; ...]; D]\n"
+ "3. IF[A != B; C; D]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}