use strict;
my $str = '1. IF[A != B; C[0]; D]
2. IF[A != B; IF[E < F; ...; ...]; D]
3. IF[A != B; C; D]';
my $regex = qr/IF\[([^][]*(?:(?<!\bIF)\[[^][]*][^][]*)*)]/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}