$re = '/IF\[([^][]*(?:(?<!\bIF)\[[^][]*][^][]*)*)]/mx';
$str = '1. IF[A != B; C[0]; D]
2. IF[A != B; IF[E < F; ...; ...]; D]
3. IF[A != B; C; D]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);