import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^///\\s*(?:<summary>)?|</summary>)(*SKIP)(*F)|(?:(?!</?summary>|^///(?!/)\\s*).)+";
final String string = "/// <summary> This is a single-line XML comment. </summary> \n\n"
+ "/// <summary> This is a multi-line XML comment.\n"
+ "/// These are additional lines with more text.\n"
+ "/// Some more of these text. </summary>\n\n"
+ "/// <summary> This is another XML text summary with a different\n"
+ "/// format.\n"
+ "/// </summary>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}