#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*: (.*)is \w* on host (.*)$"
Local $sString = "PROBLEM: FL Windows - /Solvency2.Web/api/Status is CRITICAL on host VMFLWEBTEST01" & @CRLF & _
"RECOVERY: FL Windows - /Solvency2.Web/api/Status is OK on host VMFLWEBTEST01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")