re = /^.*: (.*)is \w* on host (.*)$/m
str = 'PROBLEM: FL Windows - /Solvency2.Web/api/Status is CRITICAL on host VMFLWEBTEST01
RECOVERY: FL Windows - /Solvency2.Web/api/Status is OK on host VMFLWEBTEST01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end