$re = '/^.*: (.*)is \w* on host (.*)$/m';
$str = 'PROBLEM: FL Windows - /Solvency2.Web/api/Status is CRITICAL on host VMFLWEBTEST01
RECOVERY: FL Windows - /Solvency2.Web/api/Status is OK on host VMFLWEBTEST01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);