package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([^()]*)\)`)
var str = `I expect five hundred dollars ($500).
I expect.. :( five hundred dollars ($500).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}