re = /\(([^()]*)\)/m
str = 'I expect five hundred dollars ($500).
I expect.. :( five hundred dollars ($500).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end