#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*Three.Link resp.*$"
Local $sString = "09/10/18 20:06:07.581 DEBUG: (Radio) One.Link DONE" & @CRLF & _
"09/10/18 20:06:07.963 34, 0, 0, 0, 0, -99" & @CRLF & _
"09/10/18 20:06:08.591 DEBUG: (Radio) Two.Link request" & @CRLF & _
"09/10/18 20:06:08.601 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:02 0 .00 .00 .00 .00 0 0 0 -99 -99" & @CRLF & _
"09/10/18 20:06:08.601 DEBUG: (Radio) One.Link DONE" & @CRLF & _
"09/10/18 20:06:08.983 34, 0, 0, 0, 0, -99" & @CRLF & _
"09/10/18 20:06:09.600 DEBUG: (Radio) Two.Link request" & @CRLF & _
"09/10/18 20:06:09.611 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:03 0 .00 .00 .00 .00 0 0 0 -99 -99" & @CRLF & _
"09/10/18 20:06:09.611 DEBUG: (Radio) One.Link DONE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")