import re
regex = re.compile(r"^.*Three.Link resp.*$", flags=re.MULTILINE)
test_str = ("09/10/18 20:06:07.581 DEBUG: (Radio) One.Link DONE\n"
"09/10/18 20:06:07.963 34, 0, 0, 0, 0, -99\n"
"09/10/18 20:06:08.591 DEBUG: (Radio) Two.Link request\n"
"09/10/18 20:06:08.601 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:02 0 .00 .00 .00 .00 0 0 0 -99 -99\n"
"09/10/18 20:06:08.601 DEBUG: (Radio) One.Link DONE\n"
"09/10/18 20:06:08.983 34, 0, 0, 0, 0, -99\n"
"09/10/18 20:06:09.600 DEBUG: (Radio) Two.Link request\n"
"09/10/18 20:06:09.611 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:03 0 .00 .00 .00 .00 0 0 0 -99 -99\n"
"09/10/18 20:06:09.611 DEBUG: (Radio) One.Link DONE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")