import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*Three.Link resp.*$";
final String string = "09/10/18 20:06:07.581 DEBUG: (Radio) One.Link DONE\n"
+ "09/10/18 20:06:07.963 34, 0, 0, 0, 0, -99\n"
+ "09/10/18 20:06:08.591 DEBUG: (Radio) Two.Link request\n"
+ "09/10/18 20:06:08.601 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:02 0 .00 .00 .00 .00 0 0 0 -99 -99\n"
+ "09/10/18 20:06:08.601 DEBUG: (Radio) One.Link DONE\n"
+ "09/10/18 20:06:08.983 34, 0, 0, 0, 0, -99\n"
+ "09/10/18 20:06:09.600 DEBUG: (Radio) Two.Link request\n"
+ "09/10/18 20:06:09.611 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:03 0 .00 .00 .00 .00 0 0 0 -99 -99\n"
+ "09/10/18 20:06:09.611 DEBUG: (Radio) One.Link DONE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}