package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\#[[:blank:]]([[:word:]]|[[:blank:]]){1,}\-{1,}`)
var str = `a <- function() {
test }
lm(22)
# Secton 1 -----------------------------------
mtcars
# Section section section --------------------`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}