$re = '/\#[[:blank:]]([[:word:]]|[[:blank:]]){1,}\-{1,}/';
$str = 'a <- function() {
test }
lm(22)
# Secton 1 -----------------------------------
mtcars
# Section section section --------------------';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);