import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\#[[:blank:]]([[:word:]]|[[:blank:]]){1,}\\-{1,}";
final String string = "a <- function() {\n"
+ "test }\n"
+ "lm(22)\n"
+ "# Secton 1 -----------------------------------\n"
+ "mtcars\n\n"
+ "# Section section section --------------------";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}