#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:Citation[_ ]needed|Cn|Fact)$"
Local $sString = "Foo" & @CRLF & _
"Citation needed" & @CRLF & _
"Bar" & @CRLF & _
"Cn" & @CRLF & _
"Baz" & @CRLF & _
"Fact" & @CRLF & _
"Qux"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")