re = /(?:Citation[_ ]needed|Cn|Fact)$/m
str = 'Foo
Citation needed
Bar
Cn
Baz
Fact
Qux'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end