$re = '/(?:Citation[_ ]needed|Cn|Fact)$/m';
$str = 'Foo
Citation needed
Bar
Cn
Baz
Fact
Qux';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);