import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{2,256}\\.[a-z]{2,6}\\b([-a-zA-Z0-9@:%_\\+.~#?&//=]*)";
final String string = "http://foo.com/blah_blah\n"
+ "http://foo.com/blah_blah/\n"
+ "http://www.example.com/wpstyle/?p=364\n"
+ "https://www.example.com/foo/?bar=baz&inga=42&quux\n"
+ "http://userid:password@example.com:8080\n"
+ "http://foo.com/blah_(wikipedia)#cite-1\n"
+ "www.google.com\n"
+ "http://../\n"
+ "http:// shouldfail.com\n"
+ "http://224.1.1.1\n"
+ "http://142.42.1.1:8080/\n"
+ "ftp://foo.bar/baz\n"
+ "http://1337.net\n"
+ "http://foo.bar/?q=Test%20URL-encoded%20stuff\n"
+ "http://code.google.com/events/#&product=browser";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}