$re = '/"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"/';
$str = 'This is some text, and here\'s some in "double quotes"
"and here\'s a double quote:\\" and some more", "text that follows"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);