re = /"[^"\\]*(?:\\.[^"\\]*)*"/
str = 'This is some text, and here\'s some in "double quotes"
"and here\'s a double quote:\\" and some more", "text that follows"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end