// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""[^"\\]*(?:\\.[^"\\]*)*""#).unwrap();
let string = "This is some text, and here's some in \"double quotes\"
\"and here's a double quote:\\\" and some more\", \"text that follows\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}