package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)?([\d|\w]+)\.bandcamp\.com\/?.*`)
var str = `https://a.bandcamp.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}