$re = '/(https?:\/\/)?([\d|\w]+)\.bandcamp\.com\/?.*/m';
$str = 'https://a.bandcamp.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);