re = /(https?:\/\/)?([\d|\w]+)\.bandcamp\.com\/?.*/m
str = 'https://a.bandcamp.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end