# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\\/\\/(?:www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b(?:[-a-zA-Z0-9()@:%_\+.~#?&\\/=]*)$/\0/;t' <<< "https://dbfiddle.uk/?rdbms=mariadb_10.6&fiddle=541f0c39ba998d1d1967497a19b75c5f"