re = /https?:\/\/(?:www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b(?:[-a-zA-Z0-9()@:%_\+.~#?&\/=]*)$/
str = 'https://dbfiddle.uk/?rdbms=mariadb_10.6&fiddle=541f0c39ba998d1d1967497a19b75c5f'
subst = '\\0'
result = str.sub(re, subst)
# Print the result of the substitution
puts result