using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?:www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b(?:[-a-zA-Z0-9()@:%_\+.~#?&\/=]*)$";
string substitution = @"\0";
string input = @"https://dbfiddle.uk/?rdbms=mariadb_10.6&fiddle=541f0c39ba998d1d1967497a19b75c5f";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}