using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https://(\S*?)/v(\S*?)/|\G(?!^))([^/\s]+)/?";
string input = @"https://123/v1/a/b/
https://123343/v1/a/b/c/d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}