re = /(?:https:\/\/(\S*?)\/v(\S*?)\/|\G(?!^))([^\/\s]+)\/?/m
str = 'https://123/v1/a/b/
https://123343/v1/a/b/c/d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end