$re = '/(?:https://(\S*?)/v(\S*?)/|\G(?!^))([^/\s]+)/?/m';
$str = 'https://123/v1/a/b/
https://123343/v1/a/b/c/d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);