import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{5,8}_)+\\d{5,8}_?$";
final String string = "123456_123456\n"
+ "12345678_12345678_12345678\n"
+ "123456_12345678_123456_12345678\n"
+ "12345_123456_1234567_12345678_\n"
+ "1234567_\n\n"
+ "123456_1\n"
+ "123456_12\n"
+ "123456_1594126781\n"
+ "123_1594126781";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}