import re
regex = re.compile(r"^(?:\d{5,8}_)+\d{5,8}_?$", flags=re.MULTILINE)
test_str = ("123456_123456\n"
"12345678_12345678_12345678\n"
"123456_12345678_123456_12345678\n"
"12345_123456_1234567_12345678_\n"
"1234567_\n\n"
"123456_1\n"
"123456_12\n"
"123456_1594126781\n"
"123_1594126781")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")