package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?|(?P<one>1)|(?P<one>one))`)
var str = `1 or one, bot are matched by group one`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}