re = /(?|(?P<one>1)|(?P<one>one))/
str = '1 or one, bot are matched by group one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end