$re = '/(?|(?P<one>1)|(?P<one>one))/';
$str = '1 or one, bot are matched by group one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);