#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx) " & @CRLF & _
" (?: # ----------" & @CRLF & _
" (?= (?&V_Obj) ) # Assertion : Must be a Valid JSON Object" & @CRLF & _
" {" & @CRLF & _
" | # or ," & @CRLF & _
" (?! ^ ) # Here we are in a valid JSON Object or Array" & @CRLF & _
" \G # Continuation anchor, where we last left off" & @CRLF & _
" (?&Sep_Obj) \s* # Array Separator" & @CRLF & _
" ) # ----------" & @CRLF & _
" " & @CRLF & _
" (?: (?&V_KeyVal) (?&Sep_Obj) )*? # Drill down to array or string value" & @CRLF & _
" " & @CRLF & _
" \s* \K # Stop recording" & @CRLF & _
" ( (?&Str) ) # (1), The key" & @CRLF & _
" \s* : \s* " & @CRLF & _
" " & @CRLF & _
" (?| # Branch reset" & @CRLF & _
" \[ # Array values = string, numb, bool, or null" & @CRLF & _
" ( # (2), Array Contents" & @CRLF & _
" (?:" & @CRLF & _
" \s* " & @CRLF & _
" (?:" & @CRLF & _
" (?&Numb) # Numbers" & @CRLF & _
" | (?> true | false | null ) # Boolean and null" & @CRLF & _
" | (?&Str) # String" & @CRLF & _
" )" & @CRLF & _
" (?&Sep_Ary) # Ary separator" & @CRLF & _
" )+" & @CRLF & _
" )" & @CRLF & _
" \s* \] " & @CRLF & _
" | # Or," & @CRLF & _
" ( # (2), A Non-Ary, Non-Obj value" & @CRLF & _
" (?&Numb) # Numbers" & @CRLF & _
" | (?> true | false | null ) # Boolean and null" & @CRLF & _
" | (?&Str) # String" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" # JSON functions - NoErDet" & @CRLF & _
" # ---------------------------------------------" & @CRLF & _
" (?(DEFINE)(?<Sep_Ary>\s*(?:,(?!\s*[}\]])|(?=\])))(?<Sep_Obj>\s*(?:,(?!\s*[}\]])|(?=})))(?<Str>(?>"[^\\"]*(?:\\[\s\S][^\\"]*)*"))(?<Numb>(?>[+-]?(?:\d+(?:\.\d*)?|\.\d+)(?:[eE][+-]?\d+)?|(?:[eE][+-]?\d+)))(?<V_KeyVal>(?>\s*(?&Str)\s*:\s*(?&V_Value)\s*))(?<V_Value>(?>(?&Numb)|(?>true|false|null)|(?&Str)|(?&V_Obj)|(?&V_Ary)))(?<V_Ary>\[(?>\s*(?&V_Value)(?&Sep_Ary))*\s*\])(?<V_Obj>{(?>(?&V_KeyVal)(?&Sep_Obj))*\s*}))" & @CRLF & _
""
Local $sString = "{" & @CRLF & _
" "key1":" & @CRLF & _
" ["value1","value2","value3","value4","value5",3.14,null]," & @CRLF & _
" "key_complex_skip":" & @CRLF & _
" ["valuec", {"subkey": [null,null,34.123] } ]," & @CRLF & _
" "key2":" & @CRLF & _
" null," & @CRLF & _
" "key3":" & @CRLF & _
" "value8"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")