$re = '/
(?: # ----------
(?= (?&V_Obj) ) # Assertion : Must be a Valid JSON Object
{
| # or ,
(?! ^ ) # Here we are in a valid JSON Object or Array
\G # Continuation anchor, where we last left off
(?&Sep_Obj) \s* # Array Separator
) # ----------
(?: (?&V_KeyVal) (?&Sep_Obj) )*? # Drill down to array or string value
\s* \K # Stop recording
( (?&Str) ) # (1), The key
\s* : \s*
(?| # Branch reset
\[ # Array values = string, numb, bool, or null
( # (2), Array Contents
(?:
\s*
(?:
(?&Numb) # Numbers
| (?> true | false | null ) # Boolean and null
| (?&Str) # String
)
(?&Sep_Ary) # Ary separator
)+
)
\s* \]
| # Or,
( # (2), A Non-Ary, Non-Obj value
(?&Numb) # Numbers
| (?> true | false | null ) # Boolean and null
| (?&Str) # String
)
)
# JSON functions - NoErDet
# ---------------------------------------------
(?(DEFINE)(?<Sep_Ary>\s*(?:,(?!\s*[}\]])|(?=\])))(?<Sep_Obj>\s*(?:,(?!\s*[}\]])|(?=})))(?<Str>(?>"[^\\\\"]*(?:\\\\[\s\S][^\\\\"]*)*"))(?<Numb>(?>[+-]?(?:\d+(?:\.\d*)?|\.\d+)(?:[eE][+-]?\d+)?|(?:[eE][+-]?\d+)))(?<V_KeyVal>(?>\s*(?&Str)\s*:\s*(?&V_Value)\s*))(?<V_Value>(?>(?&Numb)|(?>true|false|null)|(?&Str)|(?&V_Obj)|(?&V_Ary)))(?<V_Ary>\[(?>\s*(?&V_Value)(?&Sep_Ary))*\s*\])(?<V_Obj>{(?>(?&V_KeyVal)(?&Sep_Obj))*\s*}))
/mx';
$str = '{
"key1":
["value1","value2","value3","value4","value5",3.14,null],
"key_complex_skip":
["valuec", {"subkey": [null,null,34.123] } ],
"key2":
null,
"key3":
"value8"
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);